Archive

Archive for July, 2011

Central Administration Navigation in 2010

Working on a migration project has given me apple opportunity to use the revised Central Administration web site provided by SharePoint 2010. Unfortunately I’d have to conclude that in some respects it represents a retrograde step, especially in terms the usability of the site navigation.

The problem is that the navigation is not always updated based upon the context of the page you are viewing, in many cases leaving you with no option but to return to the home page and navigate through several pages to get back to your original context.

This is perhaps best illustrated with one of the more commonly used Service Applications, the User Profile Service Application. Here we are, happily browsing the User Profile Service Application:

User Profile Service Application

Clicking on the Manage User Profiles link takes us to the Manage User Profiles page:

Manage User Profiles

So far, so good you might say.

However, should you wish to return to the User Profile Service Application page you can’t using the navigation provided by the Central Administation site. The site breadcrumbs offer only one choice, to return to the Central Administration home page, and the Quick Launch links are entirely static. This is very frustrating.

I thought I had a cunning workaround for this issue; after all Central Administration is a SharePoint Foundation site and we can edit the Quick Launch ourselves to add-in commonly used links as we would any other site?

Central Admin Quick Launch

Unfortunately, this isn’t the case and no matter what you add to the Central Administration’s Quick Launch navigation configuration none of the links are ever displayed in the Quick Launch navigation bar.

So for now I’m reduced to using browser bookmarks to navigate between Service Applications.

Interestingly this isn’t the case for the administration of Timer Jobs which provides a context-based menu located above the main Quick Launch navigation:

Manage Timer Jobs

I don’t know why this wasn’t implemented for other areas of the Central Administration site. If it had been, it would make the site a lot easier to use.

MOSS Search Issues related to User Profile for Service Account

Hopefully this may prove a sanity saver for anyone else who encounters this issue…

When executing a crawl from Search Administration, the crawl log shows the following error:

The protocol handler cannot be found. Check that the handler has been installed.

Within Event Viewer management console, the Application log had the following Warning:

The start address cannot be crawled.

Context: Application 'SharedServices', Catalog 'Portal_Content'

Details:
The protocol handler cannot be found. Check that the handler has been installed. (0x80040d1a)

This prevents any crawling of SharePoint content and no amount of starting and stopping the Office SharePoint Server Search service will fix the problem.

…and this Error:

The gatherer service cannot be initialized.

Details:
The Temp folder is on a drive that is full or is inaccessible. Free up space on the drive or verify that you have write permission on the Temp folder. (0x80070660)

On starting the Office SharePoint Server Search service, the same error was noted:

Windows cannot log you on because your profile cannot be loaded. Check that you are connected to the network, and that your network is functioning correctly.

DETAIL - The system cannot find the file specified.

What happened was that the local User Profile of the service account identity used for the Office SharePoint Server Search had somehow become invalid.